Back to overview
Maintenance

Update in progress - Chapter 7 Season 2

Mar 19, 2026 at 9:42am UTC  –  Mar 19, 2026 at 6:50pm UTC
Affected services
Frontend
API

Resolved
Mar 19, 2026 at 6:50pm UTC

Updated to latest version

Created
Mar 19, 2026 at 9:42am UTC

We're updating our tooling to support the new Fortnite Season