Back to overview
Maintenance

Dropmap Update In Progress

Aug 20, 2025 at 01:16pm UTC  –  Aug 20, 2025 at 01:53pm UTC
Affected services
Frontend
API

Resolved
Aug 20, 2025 at 01:53pm UTC

Update Completed, find out information on the changes here: https://dropmap.net/blog/dropmap-reload-upload

Created
Aug 20, 2025 at 01:16pm UTC

We're updating our systems