Back to overview
Degraded
Update in progress - Chapter 5 Season 4
Aug 16 at 10:44am BST
Affected services
Frontend
Resolved
Aug 19 at 12:27pm BST
Update completed, dropmap requests now available
Affected services
Frontend
Created
Aug 16 at 10:44am BST
We're updating our internal tools to support Fortnite Chapter 5 Season 4
Affected services
Frontend