Back to overview
Update in progress - Chapter 5 Season 3
May 24 at 09:40am BST
Affected services
Frontend
Resolved
May 24 at 04:19pm BST
Update completed, dropmaps requests now available
Affected services
Updated
May 24 at 03:37pm BST
All internal tools have been updated - existing dropmaps are being updated for the new map
Affected services
Created
May 24 at 09:40am BST
We're updating our internal tools to support Fortnite Chapter 5 Season 3
Affected services