Back to overview
Degraded

Update in progress - Chapter 5 Season 2

Mar 08 at 11:33am GMT
Affected services
Frontend

Resolved
Mar 10 at 11:30am GMT

All drops have been recalculated. If you have any questions or issues, please reach out to support via live chat.

Updated
Mar 10 at 03:14am GMT

Dropmaps are still recalculating. We estimate all maps will be updated around 6 AM GMT. Having issues? Contact our support team or join our Discord for updates: discord.gg/dropmap

Updated
Mar 10 at 01:18am GMT

Positioning issues are now resolved. We're recalculating all dropmaps for optimal accuracy – they'll be ready within a few hours.

Updated
Mar 09 at 11:26pm GMT

The new map is live. We've identified an issue with drops being positioned incorrectly and are working on a fix.

Created
Mar 08 at 11:33am GMT

We're updating our internal tools to support Fortnite Chapter 5 Season 2