Work In Progress - Chapter 5 Season 1 Update
Resolved
Dec 05 at 01:13pm GMT
New map and drops are live! Thanks for your patience.
Affected services
Frontend
Updated
Dec 05 at 01:01pm GMT
Dropmap Creation has started, please open a support ticket if you require a dropmap making. WIP - dropmaps will be automatically updated for any required fixes at no extra cost
Affected services
Frontend
Updated
Dec 04 at 11:45pm GMT
All assets are exported. Drops should start being created tomorrow (05/12/2023).
Affected services
Frontend
Updated
Dec 04 at 01:37pm GMT
We're still waiting on some upstream dependencies to update before we're able to get the new map live. Another update will be posted when there's more information available.
Affected services
Frontend
Created
Dec 03 at 02:04pm GMT
We are getting everything ready for the new Season 28 update! More information will be posted as it's available.
Affected services
Frontend