Back to overview
Resolved

Update in progress - Chapter 7 Season 4

Aug 20, 2026 at 12:17pm UTC  –  Aug 20, 2026 at 1:54pm UTC
Affected services
Frontend

Resolved
Aug 20, 2026 at 1:54pm UTC

Updated to latest version

Updated
Aug 20, 2026 at 1:54pm UTC

Maintenance ended

Created
Aug 20, 2026 at 12:17pm UTC

We're updating our tooling to support the new Fortnite Season. Due to game mechanic changes this update may take longer than usual